Symptoms
- An error message appears when attempting to publish a menu
Note - You can check for errors by going to Menu > Publish Menu > View All
Causes
- A category or modifier has no items
- An item has been duplicated within the same category
- The name or description of an item is too long
- An item has a negative price
- A menu does not have store hours assigned to it
- A menu already exists for the location you're trying to publish your menu
Troubleshooting Steps
- Remove any empty category or modifier groups from the Menu and Item tabs respectively
- If there are any duplicate items in your source of truth menu in an external delivery partner, make sure these are removed
- Shorten product names to <70 characters and descriptions to <255 characters
- Edit the price of any items with negative pricing to be 0.00 or higher
- Access the Hours tab and ensure the location you're publishing to has store hours assigned to it
- If there is an existing menu for the location you're trying to publish to, ensure that this is deleted before publishing your new menu to it
Self-Serve Publish Error: Nested Modifiers
When attempting to Publish the menu through Otter, you may experience the following publishing error:
If you see “Nested modifiers are not supported by some of your services,” it means that some item(s) have modifier group(s) within its modifier group.
You can see the details of the nested modifier groups:
Here, within the “Salad Choice” modifier group, we have a modifier group called “Grilled Chicken Add On”:
As many platforms (such as mentioned here: BentoBox, ChowNow, DoorDash, Grubhub, and Ritual) do not support nested modifiers, you will be able to publish the menu on all your integrated platforms once you have removed the nested modifier from your POS menu.
In this case, an option would be to delete House Salad from POS and add two separate House Salad items:
- House Salad - $0.00
- House Salad with Grilled Chicken Add On - $3.00
Self Serve Publish Error: Empty Modifier group
These steps will walk you through fixing the menu capability error Empty Modifier group
1. Click on Publish button in the top right of the Business Manager. |
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2. Click on View all to see publish errors. |
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3. The error reads Empty Modifier group. Click on Edit to view the empty modifier group. An empty modifier group means, there are no modifier options listed within the modifier group. For example, a modifier group with the name "Add Toppings", does not have any topping options(like Add Onion, Meat, etc) to choose from. |
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4. The modifier group named "MANUAL MODIFIERS" is attached to menu items but it does not have modifier options. |
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5. Close out the Edit modifier group settings. Click on the Modifier groups tab. |
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6. Search for the empty modifier group "manual modifiers". |
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7. Select the empty modifier group and click Delete. |
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8. After the empty modifier group is deleted, publish the menu. |
Self Serve Publish Error: Negative Prices are not supported
These steps will walk you through fixing the menu capability error Negative Prices are not supported.
1. Click on Publish button in the top right of the Business Manager.
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2. Click on View all to see publish errors. |
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3. The error reads Negative prices are not supported by Owner.com. Click on View all to view the items that have negative prices set.
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4. Click on Edit button in front of the first listed item
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5. Scroll down to "Item Default price", remove the negative prices and replace them with "0". |
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6. Click on Save. |
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7. Follow the same steps to fix the rest of the prices and then publish the menu. |
If you need additional help or information, you can contact support via the following:
- Chat - Our live agents are available 24/7 to help you through your Otter device. Tap the chat button on the top right corner of the home screen.
- SMS/Text or Telephone - Send us a text or give us a call anytime at 1-888-681-8837 for prompt service from our support experts.
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