Past Due Invoices

Overdue invoice can be found under the Billing > Invoices section within your Otter Dashboard.

Causes

  • Unpaid invoice
  • Invoice payment failed
  • Locked out of account

 


 

Troubleshooting Steps

Lost Access Due to Outstanding Invoices

Otter App (Orders)
Subscription payment past due (Otter App)
Web Order Manager
app.tryotter.com
Your service has been suspended (Web Order Manager)

If you lose access to your Order Manager and Otter Dashboard because of an unpaid invoice, please follow the steps below to reactivate your account:

How to Locate Billing Invoices in Otter Dashboard

  1. Log in to Otter Dashboard.
  2. Select the Account Icon in the top-right corner, and select Billing in the drop-down menu to navigate to the billing center.
  3. Select Invoices to view all of your billing invoices.
  4. You can also select an invoice to get a detailed breakdown of the invoice.

How to Add Payment Information and Change Payment Information

  1. Log in to Otter Dashboard.
  2. Select the Account Icon in the top-right corner, and select Billing in the drop-down menu to navigate to the billing center.
  3. Select Payment Methods from the left side menu, then select Add Method or Edit under the Otter section.
  4. From the pop-up window, select either a Bank Account or Credit/Debit Card.
    • Note: A processing fee of 3% will be charged to a credit/debit card payment method.
  5. If you’re adding a new payment method, enter your bank account details or your credit/debit card information and select Add bank account/card.
  6. If you’re editing an existing payment method, select Edit.
    • You can update the Preferred payment method and Enable Autopay. Select Save to confirm changes.

 


 

Frequently Asked Questions

  1. Why do I not have a Billing section in Otter Dashboard?
    • Billing access needs to be granted by the account owner. If your user needs Billing access, please contact our Customer Success Team for assistance (success@tryotter.com).

 


Related to

Updated

Was this article helpful?

0 out of 0 found this helpful

Have more questions? Submit a request