Overdue invoice can be found under the Billing > Invoices section within your Otter Dashboard.
Causes
- Unpaid invoice
- Invoice payment failed
- Locked out of account
Troubleshooting Steps
Lost Access Due to Outstanding Invoices
Otter App (Orders) |
Web Order Manager app.tryotter.com |
If you lose access to your Order Manager and Otter Dashboard because of an unpaid invoice, please follow the steps below to reactivate your account:
How to Locate Billing Invoices in Otter Dashboard
- Log in to Otter Dashboard.
- Select the Account Icon in the top-right corner, and select Billing in the drop-down menu to navigate to the billing center.
- Select Invoices to view all of your billing invoices.
- You can also select an invoice to get a detailed breakdown of the invoice.
How to Add Payment Information and Change Payment Information
- Log in to Otter Dashboard.
- Select the Account Icon in the top-right corner, and select Billing in the drop-down menu to navigate to the billing center.
- Select Payment Methods from the left side menu, then select Add Method or Edit under the Otter section.
- From the pop-up window, select either a Bank Account or Credit/Debit Card.
- Note: A processing fee of 3% will be charged to a credit/debit card payment method.
- If you’re adding a new payment method, enter your bank account details or your credit/debit card information and select Add bank account/card.
- If you’re editing an existing payment method, select Edit.
- You can update the Preferred payment method and Enable Autopay. Select Save to confirm changes.
Frequently Asked Questions
-
Why do I not have a Billing section in Otter Dashboard?
- Billing access needs to be granted by the account owner. If your user needs Billing access, please contact our Customer Success Team for assistance (success@tryotter.com).
Related to
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