Stripe's new verification update aims to prevent fraud by requiring validation that each store is genuinely part of the multi-location chain. Ensure your stores are verified to maintain smooth operations and compliance.
Cause:
- Contact information listed in Stripe doesn't contain an @[business name] email.
Error Message:
- Blocked Payouts
- Redirected to Stripe website verification
Resolution:
Most secure option without issuing e-mails to all of other brand stores
Click here to expand walkthrough
- Create a hidden webpage on your site to showcase the contact information for all your stores.
- All Stripe needs is that hidden URL, and they'll use your corporate website to confirm that your store is indeed part of your organization.
Less secure alternative option
Click here to expand walkthrough
- Choose "No" for listing your website and for having an email related to the store.
- A text box will then appear where you can describe your business and its connection to the organization.
PLEASE NOTE: Should you encounter any issues or obstacles during the verification process, please contact Stripe Support for additional assistance.
Need help? Our support team is available via the following channels:
- Chat - Our live agents are available 24/7 to help you through your Otter device. Tap the chat button on the top right corner of your POS device.
- Telephone or SMS/text - Call or text us anytime at 1-727-268-8471 for prompt service from our Otter POS support experts.
- Email - Send us an email at otterpossupport@tryotter.com and get a response within 24 hours
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